Billing Issues
Incident Report for SearchSpring Public
Resolved
This incident has been resolved.
Posted over 1 year ago. Dec 08, 2017 - 15:00 MST
Identified
Our payment processor, Blue Fin / Capital Payments, has reported issues with billing customers’ credit cards. SearchSpring accounts that are attempting to charge are being marked as “Past Due” at this time. Due to this we will not be disabling any accounts marked as “Past Due”. Once this issue is resolved all charges will be retried. We will keep you informed of any updates as we receive them.
Posted over 1 year ago. Dec 08, 2017 - 11:41 MST