High Latency in the East
Incident Report for SearchSpring Public
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 10, 2019 - 10:38 MDT
Investigating
Failed over to the west.
Posted about 1 month ago. Aug 10, 2019 - 10:13 MDT