SMC currently unable to save new changes for Hosted UI
Incident Report for SearchSpring Public
Resolved
This issue has been resolved.
Posted about 2 years ago. Feb 27, 2017 - 13:09 MST
Identified
We have identified the issue and are working on a quick resolution.
Posted about 2 years ago. Feb 27, 2017 - 12:49 MST