SearchSpring Management Console Unavalable
Incident Report for SearchSpring Public
Resolved
This incident has been resolved.
Posted over 2 years ago. Feb 13, 2017 - 04:27 MST
Update
The SearchSpring Management Console is available again. We are still working to determine what happened.
Posted over 2 years ago. Feb 13, 2017 - 04:19 MST
Investigating
The SearchSpring Management Console is currently unavailable. We are working to identify the issue.
Posted over 2 years ago. Feb 13, 2017 - 04:15 MST